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POWERDB PRO V10 

RELEASE NOTES 

Version 10 (V10) of PowerDB Pro Software incorporates the latest features 

added to the software.  A description of the new features and the steps to 

install this version are described below. 

If you are updating from a version earlier than Version 9: 

• Contact our office before you run the update 

• Synchronize all field databases to the master before updating 

Make sure you run the installer with Windows administrative privileges.  

If you are running Windows 7 or Vista, right-click > ‘Run as 

Administrator’ on your machine. 

You are recommended to backup all databases prior to installing any 

update.   

PowerDB 10 will not affect an existing installation of version 9 or 

earlier.  To avoid having multiple versions of PowerDB installed on your 

machine, version 9 or earlier should be uninstalled.  

 

PowerDB 10 will automatically upgrade a previous installation of 10, for 

example 10.0 to 10.2, but with the identical installation options.  So if 

10.0 Advanced was first installed but not Pro, then running a newer 10 

installer will not add the Pro shortcuts.  If you want to change 

installation options, such as adding Lite or Pro, then PowerDB 10 must 

first be uninstalled. 

 

To uninstall software click on the Windows ‘Start’ icon, select Control 

Panel, and browse as follows: 

� Windows XP – Add or Remove Programs 

� Windows Vista – Programs and Features 

� Windows 7 – Programs > Programs and Features 

Version 9 or earlier will be listed as 'PowerDB' in the program list and 

Version 10 will be listed as 'PowerDB 10'.  Select the appropriate item 

and choose to uninstall. 

If Version 9 fails to uninstall or if the uninstall option is not present, 

then download and run the PowerDB installation cleaner file from 

http://www.powerdb.com/download/PdbInstallCleaner.exe.  Note that this 

installation cleaner only affects version 9 or earlier. 
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The uninstall process will not remove any custom shortcuts.  Please modify 

shortcuts as necessary, noting that the default installation directory is 

now 

"C:\Program Files\PowerDB Inc\PowerDB.v10\powerdb.exe" 

When you install Version 10 on your master database machine all LAN users 

must be logged out of PowerDB and the synchronization server must be 

closed.   

You will need to install Version 10 on all LAN machines before proceeding 

with data entry and on all field machines before synchronizing again. 

NOTE:  Do not forget to update any intermediary databases (i.e., databases 

on USB drives used for synchronization). 

During the installation please follow the instructions on the screen. 

NOTE:  When connecting to an older version’s database with a new major 

version of PowerDB (such as connecting to a v9 database with v10) PowerDB 

will prompt you to update the database schema.  Respond Yes to this 

prompt.  The software will prompt you to create a backup prior to update; 

we recommend you respond Yes to this prompt. 

Overall Application Changes 

A quick load of instrument drivers on startup will get you into the 

software more quickly.  A visual difference of note is V10 uses newer 

Windows common controls, giving a different appearance to windows, 

buttons, toolbars, etc. The Address Book dialog has a horizontal layout to 

better fit smaller screen resolutions. V10 can be installed alongside any 

earlier major version however this has limited applicability and is 

generally not recommended.   

New View Settings options will change the appearance of the data input 

screen but will not affect the printed report. Choices can uniquely be set 

for each machine at Tools > Options > View Settings for any or all of the 

following: 

• Indicate dropdown fields on forms 

• Display forms with grey background 

• Rectangular border on data entry fields 

Tools > Administration > Administrative Options provides a Force Form 

Style checkbox which forces all three new View Settings to field 

databases.   

Upload Settings button will push administrative settings from a 

Development or Field database to the Master database.  All configuration 

settings get applied to field databases at the next synchronization. 
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1. Installation Edition Options 

V10 installation will allow you to install one, two or three separate 

PowerDB Software editions on your machine. Note: the full database edition 

will now be described as PowerDB Pro.   

 

PowerDB Onboard only runs on specific Megger test instruments.  Test 

results are transferred with a standard USB drive and can then be read 

into other PowerDB editions. 

PowerDB Lite is free software allowing you to use a subset of PowerDB Pro 

test forms with Megger instruments.  Lite results are saved to files and 

can be imported into Pro. 

PowerDB Advanced allows you to use any PowerDB Pro test forms and 

instrument interfaces, including the STVI Relay Form, and has data 

trending capabilities.  Advanced results are saved to files and can be 

imported into Pro. 
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 2. New Asset Properties 

You can now indicate any assets to have up to six Category Flags (NERC 

plus 5 generic) to facilitate regulatory or management reporting 

requirements.  Right-click on an asset in the Job or Asset Tree to set 

these indicators in Asset Properties.  To run reports based on these 

settings use the Compliance Report form found in the _Reports and 

Administration folder. 

 

 

 

3. Changes to Job List Filtering 

You may select to filter the Job List to only view jobs created within a 

specific date range. You may also set your filter to only view a set 

number of jobs.   

A maximum of 1000 jobs are shown at one time in the Job List.  The ‘Show 

Maximum Jobs (Last Touched)’ filter is always added after other filters 

are applied. 
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4. User Account Properties Features 

You can select to set any of the following features on any individual User 

Account.  Restrictions will not apply to Level V Administrator accounts. 

• Hide Jobs for Which User is Not ‘Job Manager’ 

• Hide Asset Tree 

• Hide Address Book 

• Restrict Access to Job Properties 

• Restrict to User’s Region 

• Viewer Account 
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5. Enhanced AVTS Data Import 

The following are now part of the AVTS Import: 

• Asset Category Flags:  This specifies particular AVTS yes/no 

settings as asset category flags.  These flags, such as one used to 

classify an asset for NERC audits, will be set for PowerDB assets 

but will not be cleared.  To clear a flag it must be set to “no” in 

AVTS and then unchecked in the PowerDB asset properties screen. 

• Asset Attributes:  Import of AVTS string settings as attributes to 

be associated with the asset in PowerDB.  The attribute names could 

be then queried for custom reporting. 

• Unique Asset Identifier:  This allows using the AVTS Barcode ID as 

the unique Asset ID in PowerDB.  There is also an option for 

managing the tree location for these assets in PowerDB; i.e., if an 

asset is moved in AVTS then the move will be mirrored in PowerDB. 

• Evaluate All Settings:  Imports asset category flags and asset 

attributes regardless of test date.  If unchecked only AVTS settings 

for assets that were tested in the specified date range are 

evaluated for import.  Note this will still be limited to assets by 

‘Match Folders’. 

• Match Folders: This filter limits the import to AVTS assets matching 

particular folder names.  The highest AVTS folder value is specified 

in the leftmost box.  Not all values need to be used.  A second, 

third, or fourth level value can be specified while leaving higher 

levels empty. 

The following values are administrative settings for the AVTS Import and 

can only be defined by an administrator in the master database: 

• Unique Asset Identifier  

• Asset Category Flags 

• Asset Attribute Strings 

When running an AVTS import in a field database or without administrator 

privileges these sections are read-only. 

To set the administrative AVTS Import settings, access the window shown 

below by logging into a master database with an administrator level user 

account.  Open a Job and select File > Import > Import AVTS Data. Select 

your AVTS database file and specify a date range (a future date is fine 

for the purpose of configuring these settings).  Fill unique asset 

identifier, asset category flags, and asset attribute values that you will 

be using.  Press OK.  This will configure the AVTS import administrative 

settings. 
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AVTS Import Settings defined by Administrator in Master Database 

 

 
AVTS Import in a Field Database 
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6. Viewer Database and Viewer Account 

This feature allows you to create a Viewer Database for a specific Viewer 

Account, and then copy particular jobs to it.  It can be used to prepare a 

database to deliver to a customer for their records.  Or it can be used to 

allow your customer, with your instruction and permission, to retrieve 

specific jobs from your master database via a limited synchronization. 

When a user logs in to a Viewer database PowerDB will always run in Reader 

mode only.  To utilize this feature follow the steps below.  

Login to PowerDB as an administrator level user. In View > User Accounts 

create a new user account.  Set the username and password. Set the 

privilege level to Level III - Power User.  Check the Viewer Account 

checkbox.  Upload User Accounts if this step is done in a field or 

development database. 
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Create a Viewer Database at File > New Database > New Viewer DB.  Press 

Create DB, you will be prompted for 

• Database name to create 

• Login credentials for synchronization 

• Viewer User Account to put into the Viewer Database 

 

At this point the Viewer Database will only contain this single user 

account (no jobs, no assets, and no addresses). 

To associate a job with a Viewer Account go to Job Properties for a 

particular job. A job may be associated with a single Viewer Account by 

selecting the account from the Viewer Account dropdown. The Available to 

Viewer checkbox enables or disables the ability for the Viewer Account to 

retrieve the job. For a Viewer Account to be able to retrieve a particular 

job, the account must be associated with the job and the job must be set 

as ‘Available to Viewer’. 
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Job to Viewer Account associations can be reviewed at the Tools > Show 

Viewer Accounts menu.   

To move a job to the Viewer database, right-click in the Job List and 

select Copy Job to Viewer. In the Database Utilities dialog press the 

Start Transfer button.  The initial transfer to a Viewer database will be 

lengthy, and it is suggested this should be done before providing the 

database to the end user. 
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The user will be prompted with a list of jobs associated with the Viewer 

account. Click the job to transfer and press the Select button. This step 

will copy a single job from the master database into the Viewer database. 

Repeat this step for each job to be sent to the Viewer database. 

 

7. Print Report Ordering 

This feature allows you to customize the order the Job Report pieces are 

printed in. Click the Report Ordering button to set your selections. 

 

You may set the order of reports, and set page numbering to be continuous 

or restarted across Report Pieces. 
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8. Merging or Replacing Forms 

This feature is not new however it may have not been mentioned in previous 

release notes.  A ‘merge’ procedure is suggested whenever a form is to be 

retired and replaced with a new form.  The merge functionality is provided 

so that previous results in the database can continue to be viewed or 

printed with the original form version, but the original form is no longer 

available to be used for new data entry.  New results will be entered on 

the new replacement form and will be associated in the tree with the old 

results to facilitate review and trending. 

This merge functionality differs from simply retiring a form.  When a form 

is only retired, any existing results can still be viewed or printed with 

the original test form version.  The form is no longer available for entry 

of new results.  But the merge feature goes an extra step and associates 

the new form with assets using the replaced form. 

A key thing to remember in regard to merging two forms is that their 

design should be similar with respect to the tag names that are being 

used.  If trending of particular data is important, the tag names for 

those fields to be trended should remain the same on both form versions. 

The steps for merging forms are: 

1. In the Form Editor tree locate the new replacement form  

2. Right-click on this file in tree and select Move Form from the menu 

3. Select the form to be replaced and retired  

4. Press the Merge button in the dialog 
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9. Enhanced Submit Files Tool 

This feature is found at Help > Submit Files and allows you to submit 

files to the PowerDB office for support and assistance.  This window has 

been expanded to include the All Log Files option and the Open Log Files 

Directory button.  

 

10. Highest Asset Folder 

In Tools > Administration > Asset Folders tab you can now define the 

highest folder level at which assets can be added.  This allows forcing a 

minimum number of folder levels to be specified when adding an asset. 

If you use the Testing Company application style this is further dependent 

on what folder levels are linked to the Address Book.  For example, if the 

asset folder level 2 is tied to the address book, then the highest asset 

folder can be 2 but not 1. 
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11. Region Database Publishing Process 

The following is the best practice for creating field region databases 

that can be copied and distributed for use in the field. 

From a direct connection to Master database: 

Step 1: Within PowerDB, select File > New Database > New Field DB 

Step 2: Choose the location and file name for the new field database (i.e. 

C:\PdbDBs\new_field.mdb) 

Step 3: Create 1 copy of the new field database file for each region to be 

published from the Master Database, named for easy identification (i.e. 

C:\PdbDBs\RegionA.mdb, C:\PdbDBs\RegionB.mdb, etc.) 

Step 4: While viewing the Jobs listing from within PowerDB (connected to 

the Master Database), select the region name to publish from the Region 

dropdown in the toolbar (Region A)  

Step 5: Select Synchronize Region from the Tools menu to re-open the 

Database Utilities 



Page [15] 

 

Step 6: Select Publish Region from the Operation dropdown, then ensure 

that the copy of the clean field database created for the selected region 

is selected as the Secondary Database (C:\PdbDBs\RegionA.mdb) 

Step 7: Click the Publish Region button 

Step 8: Wait a MINIMUM of 5 minutes after the completion of the first 

Publish Region process, then repeat steps 5-7 to perform a second Publish 

Region to the same field database 

Step 9: Repeat steps 4-8 for each additional region database to be 

published 

Step 10: Copy and distribute the new region databases as needed 

Step 11: As long as the published region database has not been opened with 

PowerDB it can be kept “fresh” from the master database by periodically 

repeating steps 8-11. 

12. Database Management 

New or published databases, if PowerDB has not been used to connect/logon 

to them, may be copied and distributed to multiple users. 

Once you connect to a new or published database with PowerDB 

that database is “named” with a unique ID.  This database 

should then not be copied except for purpose of backup. 

A “clone database” is one of any that has been used with PowerDB and 

distributed to one or more other users for data entry and/or 

synchronization.  These databases all have the same ID.  Synchronizing 

multiple databases containing the same ID will require the user to handle 

the Synchronization Date Error screen (options shown below).  This 

situation is a result of the synchronization information recorded by the 

master from the first database to synchronize conflicting with the second 

database to synchronize. 
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Full Synchronization can be used when restoring a primary or secondary 

database from a backup.  All data is synchronized.  This option should not 

be used for cloned databases. 

 

 

 

Synchronize from the minimum of the dates can be used when restoring a 

secondary database from a backup.  It generally takes less time than a 

full synchronization.  This option should not be used for cloned 

databases. 
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Acquire a new Synchronization ID: This option should be used when 

synchronizing a cloned database.  It eliminates this problem from future 

synchronizations (acquires a new ID), and it guarantees that all new data 

entered in it will be sent to the master (full synchronization). 

13. Megger SMRT Relay Test Instrument 

Version 10 (Pro and Advanced) supports control of the Megger SMRT Relay 

Test Set as well as opening .PdbXml result files created by the 

instrument.  Before utilizing this new feature the Virtual Front Panel – 

SMRT AND MPRT STVI form must be in your database.  Once the form is 

opened, complete instructions for this application are provided by the F1 

Key or the Form Help menu. 

14. SD Myers Laboratory Data Import  

Automated import of laboratory data provided by SD Myers is now available 

in PowerDB Pro.  Form 57956 must be in your database before the first 

import of data.  Open the appropriate Job and begin the process at the 

File > Import > Import SDMyers menu.  Select the approprate .xml data file 

in the PowerDB - Import File Selection window.  Indicate if results are to 

be imported as all historical or specify a range for current results.  

Click the Open button, confirm your selections, then click the OK button.  

If folder values are not correctly aligned with the Job Tree you can 

relocate results to the appropriate folders by either renaming Job Tree 

folders or changing values inside the results.  Subsequent imports will 

match serial number/equipment type combination with previoulsy imported 

results. 
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15. Move Multiple Jobs to a Different Region 

A menu item has been added to the Edit menu which allows you to move 

multiple jobs at one time to a different region.  The Region dropdown 

selection sets focus to the Job List for the selected region. Hold the 

Ctrl button to select individual multiple rows or the Shift key to select 

a block of rows. Select the target region in the To Region dropdown. Click 

the Move button to start the move process. Remember to refresh (F5) the 

Job List after the process completes. 

16. Compact Database at Backup 

A prompt has been added to optionally compact your database after the 

backup at close of the application.  This will help reduce your file size 

which can increase unnecessarily due to standard Access behavior.  

17. New External Communications Features 

A complete list of new communication capability with instruments or data 

files is provided below.  The related form(s) for each test set or import 

are also indicated. 

� Megger SMRT – SMRT and MPRT STVI, RTS Command Terminal 

� Megger BVM - 10756 

� Megger DLRO-H200 – 90513 

� Sverker – all automated relay test forms 

� Alber Cellcorder – 10760 

� Vanguard TTR (various models)- 56502 

� Vanguard EZCT – 27650 Note: must update your existing form 

� SD Myers Data Import - 57956 

18. New Test Forms 

The following new forms have been added to the PowerDB forms library. The 

.pxd file for these forms may be downloaded from the PowerDB website and 

imported into the master database or a development database.  In the Form 

Editor or Subform Editor tree, select File > Import > Import Form PXD.  

Browse to the file(s) downloaded from the website.  Select the Intelligent 

Import option for form imports and answer other prompts as required.  

� VIRTUAL FRONT PANEL – SMRT AND MPRT STVI **  

� VIRTUAL FRONT PANEL – RTS COMMAND TERMINAL 

� 00001 COVER PAGE 

� 00002 COVER LETTER 

� Compliance Report (refer to Section 3 above) 

� 10050 - BATTERY INSPECTION 
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� 10756 – Automated battery discharge (Note: Form 10755 has 

been retired)* 

� 10760 – BATTERY TEST – CELLCORDER 

� 49900 - GENERIC MULTIFUNCTION RELAY 

� 465109 –IAC-66B 

� 57956 – SD MYERS FLUID TESTING 

� 52005 - INFRARED INSPECTION SUMMARY 

� 56006 – TTR IEC 61378-1 

� 56354 – MTO TRANSFORMER HEAT RUN TEST 

� 56357 - TRANSFORMER WINDING RESISTANCE 

� 65150 - CAPACITOR BANK TEST 

� 76000 – MICROHMMETER COOLING CURVE 

� 76000 – MICROHMMETER COOLING CURVE 

� 90510 - Note: Form has been retired * 

� 90511 – MICROHMMETER MEASUREMENTS – DLRO10X 

� 90512 – MICROHMMETER MEASUREMENTS – DLRO 200/600 

� 90513 – MICROHMMETER MEASUREMENTS – DLRO H200 

� 98006 - PF STATOR COIL TIP UP 

* please refer to Section 9 above to associate retired form results with 

newer form  

** contact PowerDB technical support (email support@powerdb.com) for 

instructions on importing the SMRT AND MPRT STVI virtual front panel form. 

An alternate process to bring in changes or additions to forms and sub-

forms is to export them from the installation database latest_forms.mdb 

and then import them into your master database. To do this, follow steps 

1-9 below to update from the latest_forms.mdb  

These steps must be repeated for each file. 

1. Select File > Change Database.  Make note of the location of 

the currently active database. 

2. Browse to locate the directory where you have installed 

Version 10  

(probably C:\Program Files\PowerDB Inc\PowerDB). 

3. Locate and select Latest_Forms.mdb , click OK. 

4. The software will prompt you that PowerDB must restart, click 

OK. 

5. PowerDB will restart in Latest_Forms.mdb.  Logon to PowerDB 

with the User Name ‘administrator’.  You can view and print 

the new test forms to determine if you wish to import these to 

your existing database or view and print them from the .pdf 

file on the installation CD.  For the new forms you wish to 

add to your forms library, right-click on a form name in the 

Form Definitions tree and select “Export Form (*.pxd)”.  Make 

note of the directory where you save the file.  You may repeat 

this step for each test form you wish to export. 
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6. Select File, and then select Change Database.  Browse to the 

original database location noted in Step 1 above.  Click OK. 

7. The software will prompt you that PowerDB must restart, click 

OK. 

8. Logon to PowerDB. 

9. In the Form Editor or Subform Editor tree, select File > 

Import > Import Form PXD.  Browse to the file(s) saved in Step 

5 or downloaded from the website.  Select the Intelligent 

Import option for form imports and answer other prompts as 

required.  

19. PowerDB User Tools and Tips 

� To print a blank job with header and nameplate information 

complete the following steps: 

• In the Job List, copy/paste the previous job 

• In the Print Job Results dialog, respond ‘Yes’ to 

including blank forms.  Note: pages will not be 

numbered. 

 

• In the dialog below be sure NOT to select ‘Indicate 

Entry Fields’ 



Page [21] 

 

 

 

� Restrictions can be tightened to prevent users who are ‘Power Users’ 

(or lower) from deleting jobs and assets. 

� Restrictions can be relaxed to allow user levels other than 

Administrator to be able to register or remove a softkey license.  

To set this item go to Tools > Administration > Advanced Options 

tab. 
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� If you lose the tools palette while working in the forms 

editor go to the View menu and select Restore Windows 

Positions. 

� If you notice a long delay when opening test forms in very 

large Jobs, go to Tools > Options and check the box 

“Optimize Asset Tree for Large Jobs”. 

� You may call Megger’s Technical Support Group at  

(800)723-2861 ext. 3519 for PowerDB Support. 

� PowerDB softkey licenses are machine specific.  Before you 

replace a computer or upgrade the hard drive, be certain to 

un-license PowerDB from that machine.  Failing to do so 

could result in the loss of that license. 

� If you get a warning that there is no data found when you 

attempt to print a job, then run the “Validate Database” 

option under the Tools menu. 

� Visit our website at www.powerdb.com for more product 

information or to download the latest version of PowerDB. 


