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POWERDB REV9 

RELEASE NOTES 

Version 9 of PowerDB Acceptance and Maintenance Test Data Management 

Software incorporates the latest features added to the software.  A 

description of the new features and the steps to install this version are 

described below. 

If you are updating from a version earlier than Version 7 

please contact our office before you run the update. 

If you are a multi-license user using field databases you are 

recommended to synchronize all field databases to the master before 

updating.   

You are recommended to backup all databases prior to installing any 

update.  Due to changes in the Version 9 installation file you will 

need to uninstall previous versions of PowerDB in your Program 

Files directory.  Click on the Windows ‘Start’ icon and select 

Control Panel.  Next, browse as follows to Uninstall PowerDB. 

� Windows XP – Add or Remove Programs 

� Windows Vista – Programs and Features 

� Windows 7 – Programs > Programs and Features 

If you do not uninstall first you will see the window below. 

 

You should proceed to uninstall at this point. If PowerDB fails to 

uninstall or if the Uninstall option is not present, then download 

and run the PowerDB installation cleaner from   

http://www.powerdb.com/download/PdbInstallCleaner.exe 

When you install Version 9 on your master database machine all LAN 

users need to be logged out of PowerDB.  You will need to install 

Version 9 on all LAN machines before proceeding with data entry and 

on all field machines before synchronizing again. NOTE:  Do not 

forget to update any intermediary databases (i.e., databases on USB 

drives used for synchronization.)  
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Follow the instructions on the screen.  NOTE:  PowerDB will prompt you to 

update databases used with previous versions of PowerDB. You will be 

prompted to update the schema when connecting to a particular database 

with PowerDB for the first time.  Respond Yes to this prompt. The software 

will prompt you to create a backup prior to update; we recommend you 

respond Yes to this prompt. 

 

1. OVERALL APPLICATION  

Improvements have been added to PowerDB 9 in database validation and 

integrity sweeps. Enhanced text capability has been added to the 

application to allow you to add document-like reports to your database.  

The synchronization logic has been redeveloped to optimize efficiency and 

eliminate conflict resolution.  Please see sections below for full 

descriptions related to enhanced text and synchronization features. 

DUE TO THE NEW SYNCHRONIZATION LOGIC PLEASE BACKUP BOTH DATABASES BEFORE 

YOU SYNCHRONIZE FOR THE FIRST TIME AND EXPECT YOUR FIRST SYNCH TO TAKE 

LONGER THAN USUAL.SYNCHRONIZATION OF RESULTS IS NO LONGER JOB BASED. ALL 

RESULTS ASSOCIATED WITH SYCHRONIZED REGIONS WILL BE IN BOTH DATABASES 

AFTER SYNCHRONIZATION.  

It is recommended that you update your ‘Job MultiUse Report’ (comments and 

deficiency) subform.  This update is required if you use the combined 

summary report or the variable length comments subform on any of your test 

reports.  You most likely will experience printing problems if this 

subform is not updated. 

 

2. NEW METHOD TO UPDATE FORMS AND SUBFORMS 
You can now download .pxd file additions and updates directly from our 
website. This eliminates the steps to change databases to Latest_Forms.mdb 
and back to your master database.  www.powerdb.com/formlibrary 
 
 

3. EXTERNAL DOCUMENTS DISPLAYED IN ASSET AND JOB TREE 
If an external document is associated with an asset it will display the 
icon below in the tree. 
 

 
 

Multiple external documents can be attached to test forms/assets in the 
selected job tree.  External documents do not print from within PowerDB.  
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Please note that adding external documents into your database can inflate 
the file size significantly. 
 

4. SET FORM PREFERENCES 
To customize your form selections you may set a preference flag in the 
Form Editor tree. Right-click on a file and select Properties. Check the 
Preferred Form checkbox. 
 

 
 

In the Add to Job Wizard select to view Preferred Forms. 
 

 
 
 

5. ENHANCED TEXT DOCUMENT REPORT 
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You may add a document-like form to your Job.  This might be used for 
purposes such as a transmittal letter or inspection report.  This form can 
be printed as part of your job results.  Remember to save at intervals as 
you build your document form. 

 
To utilize this feature import the following form into your Form Editor 
tree >> 11111 – DOCUMENT located in the Miscellaneous / General family 
folder. Form 11112 is also available and includes a standard form header.  
This form can be added to any Job via the Add to Job wizard. Once added to 
a Job, open the form. To start building your form left-click in the 
following area.  
 

 

 

Then click the Add Section Below button. 

 

 

This will display the DocProperties screen to select what you want to add 

to the form. Selections include: 

• Page Break 

• Divider 

• Cover Page (large font, centered text) 

• Left Justified Text 

• Centered Text 

• Various Image/Caption combinations 
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The selected editable area will appear white on the gray background. Click 

in the area to add your text or image. 

If the item added includes a text area you will see the following. 

 

You may resize the text area left/right or up/down by grabbing the red 

handles with your mouse.  You may paste into this area from another 

document but it is not recommended to paste images in this type control as 

it will bloat your file size, use an image control instead. 

You will also be able to select font style, font color, bold, italic, 

underline and strike out. 

 

Below is an example of an image/captions option. 



Page [6] 

 

Image with Right Caption 

 

To populate an image left-click in the image area and browse to the 

desired file. To populate a caption click in the caption area and enter 

the caption text. Resize as necessary.  

You may add arrows, circles or ellipses on an image. Right-click on the 

image and select Add Shape. Arrows will be drawn from where you first 

click, pointing toward the spot you release your mouse button. Right-click 

again to add additional shapes, to remove last shape or remove all shapes. 

 

 

 

To start building the next area of your form left-click in the following 

area again. You may remove a section by clicking this same tool. 

 

Then click the Add Section Below button again. 
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6. Enhanced Text Controls in Form Editor 

There is a new control on the forms tool palette to add enhanced text 

input fields on forms. 

 

 

If selected the icon will add an enhanced text field on to the form 

workspace.  This is handled much like a text input field with the 

following additional features. 

• The area can be resized and can overlap other fields.  

• The text can be formatted as to font style, font color, bold, italic, 
underline and strike out as you enter data. 

• The text area can display simple formatting from other applications 
(Microsoft Word) such as font size and color. It will not support certain 
number and bullets characteristics. 

• Text input will word wrap within the perimeters as sized. 

• Spell checking is not available in these input fields. 
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7. NEW SYNCHRONIZATION LOGIC – AKA DELTASYNCH 

NOTE: DUE TO TIME STAMP LOGIC USED BY SYNCHRONIZATION IT IS IMPORTANT THAT YOUR MACHINE 
IS SET TO THE ACCURATE DATE AND TIME.  WE SUGGEST THAT YOU FLAG YOUR WINDOWS TIME TO 

AUTOMATICALLY SYNCHRONIZE WITH AN INTERNET TIME SERVER (EXAMPLE: TIME-NW.NIST.GOV) VIA  

CONTROL PANEL> DATE AND TIME> INTERNET TIME TAB> CHANGE SETTINGS 

 

The synchronization logic of PowerDB – Database Utilities has been 

rewritten to streamline data transfer and eliminate conflicts. Prior to 

Version 9 a set of test results was handled as a single file. If changes 

to the same results file were made in two databases since the last 

synchronization a conflict situation resulted requiring user input to 

resolve.  

The new DeltaSynch approach handles each results field individually thus 

virtually eliminating a conflict situation.  If there is a conflict in a 

data field between the two databases, it is automatically resolved by the 

system picking the most recently modified value. However results fields, 

jobs, addresses, and external documents have archives or ‘Deltas’ which 

allow the user to rollback a change if the automatic date-driven conflict 

resolution does not select what the user intended, or if the user needs to 

undo a change.  

Below is a table defining different operation types. Note: Master can be 

the Secondary DB only if the Primary is also a Master. 
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OPERATION TYPE DIRECTION PERMISSIONS PRIMARY 

DB TYPE 

SECONDARY 

DB TYPE 

Synchronization:    

Region 

(includes address 

book) 

Primary <--> Secondary M,F M,F 

Config(optionally 

may include address 

book) 

Primary <--> Secondary M,F M,F,D 

Download:    

Point in Tree Primary --> Secondary M,F M,F,D 

Upload:    

User Account Primary <-- Secondary M M,F,D 

Form Primary <-- Secondary M D 

Subform Primary <-- Secondary M D 

Curves Primary <-- Secondary M D 

Database Types: 

M-Master 

F-Field 

D-Development 

DUE TO THE NEW SYNCHRONIZATION LOGIC PLEASE BACKUP BOTH DATABASES BEFORE 

YOU SYNCHRONIZE FOR THE FIRST TIME.  UNLESS THE STEPS DECSRIBED IN THE 

PUBLISH REGION SECTION BELOW ARE FOLLOWED EXPECT YOUR FIRST AND SECOND 

SYNCH TO TAKE LONGER THAN USUAL. 

SYNCHRONIZATION OF RESULTS IS NO LONGER JOB BASED. ALL JOBS AND RESULTS 

ASSOCIATED WITH THE SYCHRONIZED REGION WILL BE IN BOTH DATABASES AFTER 

SYNCHRONIZATION. 

 

REGION SYNCHRONIZATION 

Version 9 will require you to use regions.  A region can be defined by 

geography, facility, division, department, office, district or any 

grouping that exists in your organization.  If you have not previously 

enabled regions (found at Tools>Administration>Database Options) the 

Version 9 update will automatically enable regions and place all Jobs, 

Addresses, and User Accounts into a default system region named Not 

Specified.  

If your business requires only a single region you may leave your jobs, 

user accounts and addresses in the default Not Specified region and 

proceed as usual.  Be aware that all jobs and data will be synchronized 

between master and field databases.  
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If you enable any other region then you will be required to assign regions 

to all jobs, addresses and user accounts before you will be able to 

synchronize. Jobs and data remaining in the default Not Specified region 

will not synchronize. 

Note: Not Specified and Cross-Regional are system regions and are set to 

Enabled by the application. This status cannot be changed. These regions 

can be renamed. Other regions can be added or renamed. 

  

DeltaSynch relies on Regions to synchronize databases. Users will be able 

to synchronize their data based on what region is currently active. Region 

Synchronization is unmanned meaning after the synchronization process 

starts, it is automated with no user intervention required.  Changes, 

updates and results are synchronized with ‘keep most recent date’ logic 

prevailing. 

When synchronization is launched the selected region is updated in both 

databases for all jobs, assets, results, addresses and user accounts. 

Region assignment is based on the most recent region change to an item.  

Only data that has been modified or added since the last Region 

Synchronization is processed based on the last Region Synchronization 

Date. This date can be ignored through a setting if it is necessary to 

resynchronize all data (this is described later). 
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1. Select your primary and secondary database. If one database is the 

master, it should be the primary. Under the "Operation" drop down box in 

the top right, select "Transfer Data".  

2. In the "Transfer Options" area, select "Region Synch"  

3. If you want to synchronize all data in the databases ignoring the last 

synchronization date then check the "Full Synchronization" under the 

Advanced Options button. WARNING: Checking this option will cause all data 

in the region to be resynchronized and the process will be slowed.  

4. If you want to only synchronize addresses in the active region, select 

the "Addresses in Region" option under the Advanced Options button. If you 

would like to synchronize all of the addresses in the databases, select 

the "Full Address Book" option. WARNING: Checking this option will cause 

all addresses in the database to be resynchronized and the process will be 

slowed.  
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Advanced Options 

 

• During the Synchronization the status dialog will be visible.  

 

 

• In the top right are counts displaying how many records have been 
analyzed on the primary and secondary databases, and how many records have 
actually been updated in both databases.  

• In the bottom right, important status and update messages are 
displayed. Please use the scroll bar to view this entire section. 

• On the left side is the Check List. After the synch and verification 
are finished there are three states the check boxes can be in.  

1. If Check List fields are blue with a check, the process completed 
without exception.  
2. If Check List fields are yellow with an exclamation mark, then there 
was a warning. A warning lets the user know that there is a record in one 
database that did not have a match in the other database. However, the 
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record was not supposed to move due to the synchronization rules. This 
occurs most often in a Point in Tree Download process because records are 
only allowed to move one direction, Primary->Secondary.  
3. If Check List fields are red with a Question mark, then there was a 
verification error and the synchronization dates are not updated.  If this 
situation occurs please immediately go to Help>Submit Files and submit 
your synchronization log files.  

Regions for individual jobs are set in the General tab of Job Properties. 

 

Region assignment for multiple jobs can be set from the Edit menu > Move 

Jobs to Region.    

Regions for addresses are set in the Address Book. 
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Regions for user accounts are set in each user account. 

 

 

Configuration Synch 

• This can be run by launching Database Utilities and selecting the 

Configuration Synch check box. 

• This synchronizes the configuration settings (found at 

Tools>Administration), forms, subforms, addresses, user accounts, regions. 

• This is a true synchronization going both directions   

Primary< -- >Secondary 

• Like the Region Synch this synchronization uses a Config Synch Date to 

keep track of when the last synchronization was done and only moves new 

changes. This Config Synch Date can be ignored if the user needs to 

resynchronize all configuration data (selected at the Advanced Options 

button).  

• The user has the option of synchronizing the full address book, or no 

addresses (selected at the Advanced Options button).  

Point In Tree Download  

• This takes a point in the primary database asset tree or job tree and 

pushes all assets, results, and their associated data to the secondary 

database.  

• This is one-direction only, pushing from the primary to the secondary 

(primary --> secondary) 

• This does not remove anything from secondary database, it just pushes 

items from the primary to the secondary.  
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• No Jobs are sent to the secondary and jobs will not be added to the 

secondary Job List.  

• This is launched by right-clicking at a folder level in the primary 

database Asset Tree and selecting Point in Tree Download.   

 

User Accounts Upload  

• Must have Administrator rights to run a User Account upload.  

• Upload account changes from a Secondary database to the master 

database.  

• Any User Account changes made in a field or development database do not 

go into effect immediately. To activate changes, run the User Account 

operation in Database Utilities to upload to the master. User Account 

changes in the master must be passed back down to activate in the 

secondary database.  

• This operation is launched in the User Account list. Right-click in the 

list. If there are User Account changes there will be a right-click menu 

item to upload user accounts. After the User Account upload is finished, a 

Config synch is run automatically to synchronize the changes back down to 

the secondary.  

Form Upload  

• This is a Development Database only operation which will upload a 

single form, its subforms, external documents, help and form update 

descriptions to the Master Database.  

• One direction from secondary to primary  

• This upload is launched by right-clicking a form in the Form Editor 

tree and selecting Upload Form to Master.  

• NOTE: Must be in a Development Database to have this upload option 

available.  

Subform Upload  

• This is a Development Database only option which will send a single 
subform, its external documents, Help and update descriptions to the 
Master Database.  

• One direction from secondary to primary  

• This can be launched by right-clicking a subform in the Subform Editor 
tree and selecting Upload Subform to Master.  

• NOTE: Must be in a Development Database to have this upload option 
available.  
 
Curves Upload  
 

• This is launched in a Development Database by opening the Curve Library 
dialog found in the View menu. Select the curve(s) that you want to upload 
to the master and click the "Upload Curves" button. 

• Uploads the selected Curve(s) to the Master Database.  

• One direction from Development Database to Master Database. 
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8. SUGGESTED STEPS TO PUBLISH NEW REGION FIELD DATABASES 
Below are the suggested steps if you are a multi-license user using field 
databases.  All results should be synchronized to the master prior to 
updating to Version 9. Backup all field and master databases.  The steps 
below are the suggested process as it will avoid each existing field 
database from individually doing the initial synchronizations which can be 
lengthy.   

After the master database has been updated to V9 open the master database.   

• IF YOUR BUSINESS REQUIRES ONLY A SINGLE REGION you may leave your 

jobs, user accounts and addresses in the default Not Specified 

region and proceed as usual.  Be aware that all jobs and data will 

be synchronized between master and field databases, in other words 

every field database will be a duplicate of the master.  

• IF YOU ENABLE ANY REGION other than Cross-Regional and Not 

Specified, or already have region assignments you will be required 

to assign regions to jobs, addresses and user accounts before you 

will be able to synchronize this data. Jobs and data remaining in 

the default Not Specified region will not synchronize.  Region 

assignments are set at Tools > Administration > Database Options > 

Edit Regions. Remember Jobs left in the Not Specified region will be 

orphaned in the master and will not synchronize.  

  

• Note: Not Specified and Cross-Regional are system regions and are 

set to Enabled by the application. This status cannot be changed. 

Other regions can be added or renamed. 

• Prior to creating new databases assign all active User Accounts, 

Jobs and related address book information to the appropriate 

regions. 

• Create a new field database. Do not connect to the field database. 

• Do a Configuration Synch including Full Address Book (found under 

Advanced Options) between the master and the new field database. Do 

not connect to the field database. 

• Create the required number of copies (one per region) of this blank 

Config Only field database. Rename copies as appropriate for easier 

identification. 
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• For each copy of the Region Field Database do a Publish Region 

Synchronization from the master of the appropriate region to the 

appropriate copy of the field database.  Wait five minutes after the 

synchronization completes and REPEAT this Publish Region Synch.  At 

this point these databases have never been connected to and do not 

have a database ID assigned. You can keep a copy of each Region 

Field Database and continue to ‘Publish’ to it in the future, 

providing a copy of this file to new users. 

• Distribute the copies of the Region Field Database to each user.  

The first time the database is connected to an ID will be assigned 

and will uniquely tag this database going forward.   

9. WHAT ARE DELTASYNCH ‘DELTAS’? 
Stepping forward and back between Delta Sessions as described below is 

intended to be used only as a recovery tool means to recapture saved 

values.   

CONFLICT - defined as a data value that has changed in both databases 
since the last synchronization 

DELTA SESSION - started by opening a result (new or old); all changes 
made to the results and saved are applied to the Delta; if more changes 

are made to the results and saved again all new changes are applied to the 

same Delta because the user is in the same (open) Delta Session; all 

changes and saves will continue to apply to the open Delta Session until a 

new Session is started – NOTE: only the last ‘save’ in a Session is 

retrievable.  A Delta Session is ended by closing the results, reopening 

the same result, opening another result or creating a new result.   

PowerDB Version 8 and prior treated a set of data results in its entirety 

as a single record.  If any data value(s) in a results record had been 

changed in both synchronizing databases since the last synchronization a 

conflict situation was created requiring user intervention to resolve. The 

new DeltaSynch approach handles each results field individually thus 

virtually eliminating a conflict situation.  If there is a conflict in a 

data field between the two databases, it is automatically resolved by the 

system picking the most recently modified value. However results fields, 

jobs, addresses, and external documents have archives or ‘Deltas’ which 

allow the user to selectively rollback a change if the automatic ‘last 

date saved wins logic’ does not select what the user intended, or if the 

user needs to undo a change.  

To view the Deltas for a result the user needs to open the result.  In the 

toolbar are 4 arrows to allow the user to step forward and back through 

Delta Sessions. 
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1-Steps back to the very first saved Delta Session 

2-Steps back one Delta Session from the session currently displayed 

3- Steps forward one Delta Session from the session currently displayed 

4-Steps forward to the most recent Delta Session saved 

As you step back and forward between Delta Sessions, all affected data 

fields will show green if the saved value has changed between Delta 

Sessions. To recover one or more values from a previous Delta Session, 

right-click in a data field and select Pull Fields From History. Then 

shift-click on one or more fields to be changed. The user will be returned 

to the current Delta Session and the pulled values will be set into the 

fields.  To keep these changes, the results must be saved as modified; 

otherwise the changes will be discarded if not saved. 

Note: Due to scripting logic some header and calculated fields may appear 

green indicating a change when in fact there has not been a change.  

Please focus on data entry fields as you step back and forth through delta 

sessions. 

Changes made to an asset such as its name and tree location can be viewed 

and restored from the Asset or Job Tree right click menu item View Outside 

Relay Changes. These changes are not related to Delta Sessions. 

 

10. DEVELOPMENT DATABASE 

Certain processes MUST be done in a ‘Development Database’. These are 

limited to: 

• Form Editor maintenance 

• Subform Editor maintenance 

• Curve Library maintenance 

Development Databases can only be created from a master database. To 

create a Development Database go to File > New Database > New Development 

DB or go to Database Utilities and select ‘Create New Development 

Database’.  To connect to this database go to File > Change Database or 

log in again and change database. You will be required to use a user 

account other than the Administrator account to apply changes made in the 

Development Database to the Master Database.  
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Changes made in the Form Editor must be uploaded to the master database 

using Database Utilities or by exporting the .pxd file of the modified 

form. Migrating form changes via either method is accomplished one form 

file at a time. Uploaded or exported files will also include and affect 

all subforms that are used in the form; exception to subforms 

automatically being updated follow existing Intelligent Import rules 

skipping logos, headers, footers, comments, and dividers. To move form 

modifications via the upload method right-click on the form in the Form 

Editor tree and select Upload Form to Master. Changes will propagate from 

the master to field databases at the next synchronization.  Form deletions 

made in the Development Database will not get pushed to the master 

database. To inactivate a form in the master database (remove from 

available forms to be added to a Job) right-click on the form in either 

the development or master database form editor tree and select Retire 

Form.  If a form is retired in the Development Database and you want to 

push this change to the master database you must go to View > Form Folder 

Options > View Retired Only, then right-click on the form and select 

Upload Form to Master. 

Changes made in the Development Database Subform Editor must be uploaded 

to the master database using Database Utilities or by exporting the .pxd 

file of the modified subform. This is accomplished one subform file at a 

time unless the subform is included in a form that is uploaded.  Right-

click on the subform in the Subform Editor tree and select Upload Subform 

to Master. Changes will propagate from the master to field databases at 

the next synchronization.  Subforms cannot be viewed or tested outside of 

the Development Database. Deletions in the Development Database cannot get 

propagated to the master.  You can make form and subform deletions in the 

master database. 

When saving a change to a form or subform the dialog below will display.  

This provides a means to track who, what, when and why forms and subform 

changes are made.  Completing this window is optional and you will be able 

to save your changes in any case. 
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To view information tracked in the dialog above open and run Form Update 

Report in the _Reports and Administration/Report form family the form 

editor tree. 

Changes made to the Curve Library must be uploaded to the primary 

database.  You may select one, multiple or all curves, to be added or 

deleted. Changes will propagate from the master to field databases at the 

next synchronization.  To delete curves in the Development Database and 

affect this change in the master database go to View > Curve Library, 

check the box for View deleted Curves, select the curves to delete and 

click the Upload Curves button. 

 

You may also make changes to User Accounts in a Development Database, 

field or master database.  If changes are made in the Development Database 

maintain the user accounts as required, right-click in the User Account 

list and select Upload User Accounts. All User Accounts will move in their 

entirety as a single file. After the User Account upload is finished, a 

Config synch is run automatically to synchronize the changes back down to 

the secondary database. 

You can test your form, subform and curve library changes in the 

development database.  For example you can create jobs and add results but 

these job records can never be moved outside of the Development Database. 

11. CHANGES TO MOVING SOFTKEY LICENSES 

Restrictions can be relaxed to allow user levels other than Administrator 

to be able to register or remove a softkey license.  To set this item go 

to Tools > Administration > Advanced Options tab. 



Page [22] 

 

 

12. CHANGES TO ASSET TREE FILTERING 

When the database contains a large amount of data, the Assets listing may 

consist of a very long list, making it difficult to locate a specific 

piece of information.  Filter Settings may be applied so that only a 

subset of the entire listing is viewed at one time, making it easier to 

locate a specific asset or group of assets.  

The filtering control button appears on the tool bar with an icon that 

resembles a funnel .  Pressing this button causes the following dialog box 

to appear.  Recent changes to this screen are highlighted. 
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When the dialog box is open, the filter button will not be visible on the 

tool bar.  

Changes to Filter Settings are applied to the Asset Tree.  They can be 

applied one at a time, or multiple settings may be applied at the same 

time.  Once Filter Settings are made, the dialog box may be closed by 

pressing the close button , at which time the settings take effect.  

Filter Settings will remain in effect until they are manually removed by 

re-opening the dialog box and changing or removing settings.   

The filter that applies when viewing the Asset Tree does not affect the 

Jobs listing or the Selected Job tree.  

 

13. JOB TREE FILTERING 
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When the database contains a large amount of data, the Selected Job tree 

may be very long, making it difficult to locate a specific piece of 

information.  Filter Settings may be applied so that only a subset of the 

entire tree is viewed at one time, making it easier to locate a specific 

asset or location in the tree.   

The filtering control button appears on the tool bar in the application 

with an icon that appears to look like a funnel .  Pressing this button 

causes the following dialog box to appear.  Recent changes to this screen 

are highlighted. 

 

When the dialog box is open, the filtering control button will not be 

visible on the button bar.  

Changes to Filter Settings are applied to the Selected Job tree.  They can 

be applied one at a time, or multiple settings may be applied at the same 

time.  Once Filter Settings are made, the dialog box may be closed by 

pressing the close button , at which time the settings take effect.  

Filter Settings will remain in effect until they are manually removed by 

re-opening the dialog box and changing or removing settings.   
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The filter that applies when viewing the Selected Job tree does not affect 

the Assets list or the Jobs list. 

14. JOB LIST FILTERING 

When the database contains a large amount of data, the Job List may be 

very long, making it difficult to locate a specific piece of information.  

Filter Settings may be applied so that only a subset of the entire listing 

is viewed at one time, making it easier to locate a specific job or group 

of jobs.  

The filtering control buttons appear on the button bar in the application 

with icons that resemble funnels .   

 - This button, when pressed, causes all Active jobs to appear in the 

Jobs list.  Releasing this button from the depressed position will remove 

all Active jobs from the list view.  

 - This button, when pressed, causes all Completed jobs to appear in the 

Jobs list.  Completed jobs appear with a “C” in the column directly to the 

left of the job number.  Releasing this button from the depressed position 

will remove all Completed jobs from the list view.  

 - This button causes the following dialog box to appear.   
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When the dialog box is open, the filter buttons will not be visible on the 

tool bar.   

Changes to Filter Settings are applied to the Job List.  They can be 

applied one at a time, or multiple settings may be applied at the same 

time.  Once Filter Settings are made, the dialog box may be closed by 

pressing the close button , at which time the settings take effect.  

Filter Settings will remain in effect until they are manually removed by 

re-opening the dialog box and changing or removing settings.   

The filter that applies when viewing the Job List does not affect the 

Assets Tree or the Selected Job Tree.  

15. INFRARED IMAGES 

In the Form Editor tree a new Infrared family has been added.  

Form 52225 – Infrared Report allows you to report up to four image files, 

infrared or digital.  When used as a results form in data entry mode, 

after an image has been brought in you can right-click on the image to add 

shapes.  Available shapes include a circle, ellipse or arrow. The right-

click menu allows for removing the last shape or all shapes.  This 

add/delete process can be done multiple times until you get the shape and 

placement in the desired position.  

Form 45455 – Infrared Inspection allows you to display infrared and 

visible images captured with the FLIR model P65, indicate problem and 

references points on each image and add connecting lines if desired. 

 

Various palette selections can also be made. 



Page [27] 

 

 

16. NEW EXTERNAL COMMUNICATIONS FEATURES 

PowerDB version 9 offers communication with the Megger Delta 4000 series 

Power Factor Test Set.  This includes both live data capture and data 

import capabilities.  This instrument communicates with the same PF forms 

as the Delta 2000 and Delta 3000. 

PowerDB version 9 offers communication with the Megger MTO 300/330 

Transformer Ohmmeter test set.  You must update your forms library with 

form 56353 in the transformer family. 

PowerDB version 9 offers communication with the following models of the 

Megger Oil Test Set: OTS6AF, OTS80AF, OTS100AF, OTS60PB, and OTS80PB. You 

must update your forms library with form 57390 in the insulation fluid 

family. 

PowerDB version 9 offers data import of Vanguard ATRT-03S2 results. You 

must update your forms library with form 56202 in the transformer family.  

To import these results sets add the form to your PowerDB job, right-click 

in the form and select Import Data from Vanguard.  

PowerDB Version 9 offers data import of CABA Win software results used to 

operate Megger circuit breaker analyzers such as the EGIL, TM1600/MA61 and 

TM1800 models.  Test results can be reviewed and analyzed in PowerDB or 

re-opened in CABA Win for review or subsequent testing.  For proper 

functionality CABA Win v4.1.5.4 or greater must be used.  

PowerDB provides functionality not available in CABA Win.  This includes:  

• Synchronization of results into a central database for access by 
many users 

• Combining breaker test data with other results into a comprehensive 
formal report 

• Convenient database backup for data security 
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For CABA Win import purposes add the CabaWinImport and 

CabaWinImport_FormExport files into your Form Editor and review complete 

instructions in Form Help. 

17. ADDITIONS/CHANGES TO THE FORMS AND SUBFORMS LIBRARY 

You may affect changes to the default maintenance period for a form in the 

right-click menu Properties item in either a master or development 

database.  Similarly you may also indicate a form to be a ‘Preferred 

Form’. 

 

Flagging a form as ‘Preferred’ will streamline your selection options in 

the Add To Job Wizard. 
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The following new forms have been added to the PowerDB forms library. The 

.pxd file for these forms may be downloaded from the PowerDB website and 

imported into the master database or a development database.  In the Form 

Editor or Subform Editor tree, select File > Import > Import Form PXD.  

Browse to the file(s) downloaded from the website.  Select the Intelligent 

Import option for form imports and answer other prompts as required.  

� Maintenance Report 

� CabaWinImport 

� CabaWinImport_FormExport 

� 11111 – Document 

� 11112 – Document with Header 

� 56502 – Transformer TTR (Vanguard) 

� 52225 – Infrared Report  

� 45455 – Infrared Inspection 

� 57390 – OTS Oil Test 

� 56353 – Transformer Winding Resistance 

� 95500 – PF Auto Transformer with Tertiary 

� 95501 – PF auto Transformer Without Tertiary 

� 56370 – TTR Voltage Regulator 

An alternate process to bring in changes or additions to forms and sub-

forms is to export them from the installation database latest_forms.mdb 

and then import them into your master database. To do this, follow 

steps 1-9 below to update from the latest_forms.mdb  

These steps must be repeated for each file. 
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1. Select File > Change Database.  Make note of the location of 

the currently active database. 

2. Browse to locate the directory where you have installed 

Version 9  

(probably C:\Program Files\PowerDB Inc\PowerDB). 

3. Locate and select Latest_Forms.mdb , click OK. 

4. The software will prompt you that PowerDB must restart, click 

OK. 

5. PowerDB will restart in Latest_Forms.mdb.  Logon to PowerDB 

with the User Name ‘administrator’.  You can view and print 

the new test forms to determine if you wish to import these to 

your existing database or view and print them from the .pdf 

file on the installation CD.  For the new forms you wish to 

add to your forms library, right-click on a form name in the 

Form Definitions tree and select “Export Form (*.pxd)”.  Make 

note of the directory where you save the file.  You may repeat 

this step for each test form you wish to export. 

6. Select File, and then select Change Database.  Browse to the 

original database location noted in Step 1 above.  Click OK. 

7. The software will prompt you that PowerDB must restart, click 

OK. 

8. Logon to PowerDB. 

9. In the Form Editor or Subform Editor tree, select File > 

Import > Import Form PXD.  Browse to the file(s) saved in Step 

5 or downloaded from the website.  Select the Intelligent 

Import option for form imports and answer other prompts as 

required.  

18. POWERDB USER TOOLS AND TIPS 

� To print a blank job with header and nameplate information 

complete the following steps: 

• In the Job List, copy/paste the previous job 

• In the Print Job Results dialog, respond ‘Yes’ to including 

blank forms.  Note: pages will not be numbered. 
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• In the dialog below be sure NOT to select ‘Indicate Entry 

Fields’ 

 

 

 

� If you loose your tools palette while working in the forms 

editor go to the View menu and select Restore Windows 

Positions. 
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� If you notice a long delay when opening test forms in very 

large Jobs, go to “Tools > Options” and check the box “Optimize 

Asset Tree for Large Jobs”. 

� You may call Megger’s Technical Support Group at  

(800)723-2861 ext. 3519 for PowerDB Support. 

� PowerDB softkey licenses are machine specific.  Before you 

replace a computer or upgrade the hard drive, be certain to un-

license PowerDB from that machine.  Failing to do so could 

result in the loss of that license. 

� If you get a warning that there is no data found when you 

attempt to print a job, then run the “Validate Database” option 

under the Tools menu. 

� Visit our website at www.powerdb.com for more product 

information or to download the latest version of PowerDB. 

 

 

 

 


